Request for compatible browser download

When using the service

"Google Chrome", "Firefox" or "Microsoft Edge" is required to start a lesson at Native Camp.

If you are using a non-supported browser (Internet Explorer, Safari, etc.), please download "Google Chrome", "Firefox" or "Microsoft Edge".

※If you have already downloaded "Google Chrome", "Firefox", or "Microsoft Edge", it is not necessary.

Please select one and download it.

Flow after download

  • 1. Please click the added icon to launch the browser

    Start Browser
  • 2. Search for Native Camp when your browser starts up

    Search NativeCamp.
  • 3. Visit Native Camp

    Search NativeCamp.

The native camp screen will open. Enjoy the lesson!

Please select one and download it.

If you have any questions, please contact us from here

Posting restricted

I'm sorry, but
posting to this bulletin board has been restricted due to a
post that falls under the prohibited items of Article 2 of the Native Camp Plaza Usage Rules.